Telco Switch Status
Incident Report for Giganet Status Page
Resolved
All systems are back up and running.

May 04, 2023 - 10:08 BST
Posted May 04, 2023 - 10:09 BST
Update
We are continuing to monitor for any further issues.
Posted May 03, 2023 - 17:24 BST
Update
Monitoring - Traffic for all impacted customers has now been fully restored. We continue to monitor closely and will leave the incident open both whilst our teams monitor and to allow posting of debrief in due course to this status.
Posted May 03, 2023 - 17:23 BST
Monitoring
Identified - We have identified the root cause and are rolling out resolution now. We expect service to restore for all impacted customers by 12:45. We will updated further to the status site should the position change during expected resolution. Further details on root cause will be published to this status through the course of today as our teams debrief.

Update - We continue to restore service to all customers. That's taking a little longer than we would like due to pent up demand to the platform. We are however actively restoring service to all customers. Thank you for your patience while we continue to do so.
Posted May 03, 2023 - 12:58 BST
Investigating
We are seeing significantly degraded post delay dial on inbound and outbound calls. The delay is substantial and will therefore feel like calls aren't completing. Our NOC team are aware and investigating with urgency.

Service Impact: Loss of Service

We will provide updates as we have more information and apologise for any inconvenience this may have caused.

Further updates will be provided as we learn more.

May 03, 2023 - 11:53 BST
Posted May 03, 2023 - 12:28 BST
This incident affected: Giganet - Voice Services (Giganet DBX - TelcoSwitch).